Forum SEO phpbb3

В данном подфоруме будут располагаться темы с анонсами интересных модификаций, а так же будут рассматриваться проверенные временем дополнения для phpBB3.
Правила форума
----
Аватара пользователя
DeaDRoMeO
Старожил Форума
Старожил Форума
Сообщения: 16699
Стаж: 9 лет 8 месяцев
Откуда: Витебск
Благодарил (а): 457 раз
Поблагодарили: 2127 раз

Forum SEO phpbb3

Сообщение DeaDRoMeO »

А скрипт инсталлятор кто будет запускать???
На вопросы, связанные с phpBB, по ЛС не отвечаю !!!
Аватара пользователя
Rapcoreman
Заглянул на огонек
Заглянул на огонек
Сообщения: 29
Стаж: 6 лет 8 месяцев
Откуда: Россия
Благодарил (а): 17 раз
Поблагодарили: 1 раз

Forum SEO phpbb3

Сообщение Rapcoreman »

Установил всё по инструкции, мод установился без проблем и ошибок, однако в настройках форума мод не видно......Кеш чистил раз 10, не помогло. Кто нибудь сталкивался? С остальными модами SEO проблем не было.
Аватара пользователя
DeaDRoMeO
Старожил Форума
Старожил Форума
Сообщения: 16699
Стаж: 9 лет 8 месяцев
Откуда: Витебск
Благодарил (а): 457 раз
Поблагодарили: 2127 раз

Forum SEO phpbb3

Сообщение DeaDRoMeO »

Тобишь, админка - форумы - выбираем любой подфорум, жмем напротив зеленую шестеренку, и вот там нету блока мода?
На вопросы, связанные с phpBB, по ЛС не отвечаю !!!
Аватара пользователя
Rapcoreman
Заглянул на огонек
Заглянул на огонек
Сообщения: 29
Стаж: 6 лет 8 месяцев
Откуда: Россия
Благодарил (а): 17 раз
Поблагодарили: 1 раз

Forum SEO phpbb3

Сообщение Rapcoreman »

DeaDRoMeO писал(а):Тобишь, админка - форумы - выбираем любой подфорум, жмем напротив зеленую шестеренку, и вот там нету блока мода?
Совершенно верно. Может конфликтует с чем то?
Аватара пользователя
Вредина
Начинаю осваивать Форум
Начинаю осваивать Форум
Сообщения: 129
Стаж: 6 лет 9 месяцев
Откуда: Москва
Благодарил (а): 9 раз
Поблагодарили: 2 раза
Контактная информация:

Forum SEO phpbb3

Сообщение Вредина »

Устанавливал руками?Не через автомод?
Аватара пользователя
Rapcoreman
Заглянул на огонек
Заглянул на огонек
Сообщения: 29
Стаж: 6 лет 8 месяцев
Откуда: Россия
Благодарил (а): 17 раз
Поблагодарили: 1 раз

Forum SEO phpbb3

Сообщение Rapcoreman »

Вредина писал(а):Устанавливал руками?Не через автомод?
В ручную ставил, автомодом не пользуюсь, уже три раза ставил, результат тот же.....
Аватара пользователя
DeaDRoMeO
Старожил Форума
Старожил Форума
Сообщения: 16699
Стаж: 9 лет 8 месяцев
Откуда: Витебск
Благодарил (а): 457 раз
Поблагодарили: 2127 раз

Forum SEO phpbb3

Сообщение DeaDRoMeO »

Кхмм, конфликтовать ни с чем не может мод, видимо в правках дело, просто внимательно опять попробуйте, может не все правленные файлы назад с заменой заливаются, может кеш вручную почистить? Кеш браузера?
На вопросы, связанные с phpBB, по ЛС не отвечаю !!!
Аватара пользователя
Rapcoreman
Заглянул на огонек
Заглянул на огонек
Сообщения: 29
Стаж: 6 лет 8 месяцев
Откуда: Россия
Благодарил (а): 17 раз
Поблагодарили: 1 раз

Forum SEO phpbb3

Сообщение Rapcoreman »

DeaDRoMeO писал(а):Кхмм, конфликтовать ни с чем не может мод, видимо в правках дело, просто внимательно опять попробуйте, может не все правленные файлы назад с заменой заливаются, может кеш вручную почистить? Кеш браузера?
Да, чистил, результат тот же, примечательно что на тестовом форуме на просильвере всё работает, а на моём шаблоне нет, хотя по инструкции все правки идентичны, странно....
Аватара пользователя
DeaDRoMeO
Старожил Форума
Старожил Форума
Сообщения: 16699
Стаж: 9 лет 8 месяцев
Откуда: Витебск
Благодарил (а): 457 раз
Поблагодарили: 2127 раз

Forum SEO phpbb3

Сообщение DeaDRoMeO »

Дык от шаблона тут ничего не зависит, проблема в шаблоне админки же, у вас же в админке нет нужного пункта. SQL запрос выполняли после правок?
На вопросы, связанные с phpBB, по ЛС не отвечаю !!!
Аватара пользователя
slimxl
Заглянул на огонек
Заглянул на огонек
Сообщения: 5
Стаж: 6 лет 7 месяцев
Благодарил (а): 2 раза

Forum SEO phpbb3

Сообщение slimxl »

Доброго времени суток...
На форуме стоит мод автоматически подбирающий кейвордсы ( SEO Dynamic Meta tags - Динамические мета теги. )... но я посмотрел и часто ставятся предлоги и т.п. (в ручную вбивать постоянно исключения думаю не целесообразно)...
установил анонсированный тут мод по инструкции, очистил кэш.
И в целом не понял принцип действия мода и не нашел как его включить ((( на сколько понял кейвордсы добавляются через админку, в настройках подфорумов. Что бы я не вводил кейвордсы не меняются - не добавляются.
Если все правильно, то

т.к. вместо строки..и ещё пару связанных с ней

Код: Выделить всё

<meta name="keywords" content="" /> <meta name="description" content="" />
в овералхидер стоит "переменная" {META_TAG}
как бы подружить?
или легче удалить SEO Dynamic Meta tags ?
Аватара пользователя
DeaDRoMeO
Старожил Форума
Старожил Форума
Сообщения: 16699
Стаж: 9 лет 8 месяцев
Откуда: Витебск
Благодарил (а): 457 раз
Поблагодарили: 2127 раз

Forum SEO phpbb3

Сообщение DeaDRoMeO »

Полистайте полностью тему, множество вопросов отпадет, а тот мод который у вас сейчас стоит лучше удалить
На вопросы, связанные с phpBB, по ЛС не отвечаю !!!
Аватара пользователя
Rapcoreman
Заглянул на огонек
Заглянул на огонек
Сообщения: 29
Стаж: 6 лет 8 месяцев
Откуда: Россия
Благодарил (а): 17 раз
Поблагодарили: 1 раз

Forum SEO phpbb3

Сообщение Rapcoreman »

Решил проблему при помощи автомода
vovanvi
Заглянул на огонек
Заглянул на огонек
Сообщения: 39
Стаж: 6 лет 8 месяцев
Откуда: Новоселово
Благодарил (а): 98 раз
Контактная информация:

Forum SEO phpbb3

Сообщение vovanvi »

Форум с порталом ,
Всё заработало,
правда пока не поставил все три мода сео .
Одно замечание , если сразу не получилось , даже после очистки кешей , рекомендую обождать сутки.
Почему так происходит не знаю, но замечено:
Ставлю моды в ночь , кеши почищены. Правки ещё раз проверены , всё равно не работает не появляются пункты в админке . Доступ к форуму есть база доступна, ложусь спать .Уром заходишь все пункты в админке появились, права доступа раздал и всё работает.Может быть вечером уставший, не там ищешь,как говорят глаз замыливается, а с утра на свежую голову всё видно. Или , как вариант хостер чудит.
Аватара пользователя
DeaDRoMeO
Старожил Форума
Старожил Форума
Сообщения: 16699
Стаж: 9 лет 8 месяцев
Откуда: Витебск
Благодарил (а): 457 раз
Поблагодарили: 2127 раз

Forum SEO phpbb3

Сообщение DeaDRoMeO »

Я больше склоняюсь к варианту с хостером))
На вопросы, связанные с phpBB, по ЛС не отвечаю !!!
Аватара пользователя
Alexandr
Заглянул на огонек
Заглянул на огонек
Сообщения: 44
Стаж: 6 лет 3 месяца
Откуда: Москва
Благодарил (а): 7 раз
Контактная информация:

Forum SEO phpbb3

Сообщение Alexandr »

DeaDRoMeO писал(а):SQL запрос
А что нужно написать в окне запроса в БД , подскажите пожалуйста. Видно у меня нет в базе нужной колонки и поэтому при сохранении ключевых слов выдает такую ошибку Unknown column 'forum_seo_key' in 'field list' [1054]

А все спасибо, разобрался )) Ответ на нашел опять же на вашем форуме. Спасибо !

Возник только вот какой вопрос. У меня и описание и ключевые слова выводятся на страницу подфорума, а мета тегаих ничего нет. Это нормально ? Разве так и должно быть ? Я думал именно там все буде прописываться. Или я мод криво поставил ? Вот как пример http://www.comunidadrusa.com/viewforum.php?f=9
Аватара пользователя
DeaDRoMeO
Старожил Форума
Старожил Форума
Сообщения: 16699
Стаж: 9 лет 8 месяцев
Откуда: Витебск
Благодарил (а): 457 раз
Поблагодарили: 2127 раз

Forum SEO phpbb3

Сообщение DeaDRoMeO »

DeaDRoMeO писал(а):------------------- Дополнительные правки для мода -----------------
Это для кого я писал в первом посте?
На вопросы, связанные с phpBB, по ЛС не отвечаю !!!
Аватара пользователя
Alexandr
Заглянул на огонек
Заглянул на огонек
Сообщения: 44
Стаж: 6 лет 3 месяца
Откуда: Москва
Благодарил (а): 7 раз
Контактная информация:

Forum SEO phpbb3

Сообщение Alexandr »

Если выполнить дополнительные правки, то перестанет работать Seo Topic Поэтому..я не сразу обратил внимание на это в фале overall_header.html ..в общем вот так выводятся ключевые слова и там и там...

Код: Выделить всё

<meta name="keywords" content="<!-- IF SEO_KEY -->{SEO_KEY}<!-- ENDIF --><!-- IF SCRIPT_NAME == "viewforum" -->{FORUM_SEO_KEY}<!-- ENDIF -->" />
<meta name="description" content="<!-- IF SEO_DESC -->{SEO_DESC}<!-- ENDIF --><!-- IF SCRIPT_NAME == "viewforum" -->{FORUM_SEO_DESC}<!-- ENDIF -->" />
{META}
Т.е замену я не производил, а в код недостающую часть.
Аватара пользователя
Tatyana_S
Зашел немного посидеть
Зашел немного посидеть
Сообщения: 62
Стаж: 6 лет 1 месяц
Откуда: Нижний Новгород
Благодарил (а): 26 раз
Контактная информация:

Forum SEO phpbb3

Сообщение Tatyana_S »

Поставила этот мод сегодня, сразу возник вопрос.
Вводим только ключевые слова - внизу форума отображается описание форума, которое создается при создании самого форума. Ключевые слова не видны.

Если ввести какое-то поле из тех, что ниже в SEO - описание форума и то описание, что будет отображаться - отображаются и ключевые слова и описание. Это так и должно быть? или все же должно быть все видно только для ботов? Никаких лишних строк в футере, как у Елены. я не нашла.
запросы все прошли нормально, стиль сабсильвер2.

Аватара пользователя
DeaDRoMeO
Старожил Форума
Старожил Форума
Сообщения: 16699
Стаж: 9 лет 8 месяцев
Откуда: Витебск
Благодарил (а): 457 раз
Поблагодарили: 2127 раз

Forum SEO phpbb3

Сообщение DeaDRoMeO »

В первом посте я неверно написал условие, догадаетесь как его исправить? Компа просто под рукой нет
На вопросы, связанные с phpBB, по ЛС не отвечаю !!!
Аватара пользователя
Tatyana_S
Зашел немного посидеть
Зашел немного посидеть
Сообщения: 62
Стаж: 6 лет 1 месяц
Откуда: Нижний Новгород
Благодарил (а): 26 раз
Контактная информация:

Forum SEO phpbb3

Сообщение Tatyana_S »

DeaDRoMeO писал(а):В первом посте я неверно написал условие, догадаетесь как его исправить? Компа просто под рукой нет
Сергей, это мне или Александру? если мне, то ткните, пожалуйста, носом куда надо и во что надо, а то я полдня сегодня смотрела на свои файлы и ничего не высмотрела :smu:sche_nie: :ny_tik:
Ответить